FogBugz/Manuscript On Demand is not available
Incident Report for FogBugz and Kiln On Demand
Resolved
This incident has been resolved.
Posted about 1 month ago. Nov 12, 2018 - 07:47 EST
Investigating
We are currently investigating this issue.
Posted about 1 month ago. Nov 12, 2018 - 07:32 EST
This incident affected: FogBugz Website and FogBugz API.